JavaFX : résoudre des problèmes sous NetBeans

Si jamais vous essayez de faire fonctionner l’exemple fourni ici et que rien ne marche, avec une erreur ressemblant à :

pakage javafx.ui does not exist

ou encore :

package javafx.ext.swing does not exist

C’est que vous n’avez probablement pas installé la dernière version de JavaFX.

Voici comment faire :

  1. vous allez chercher la toute dernière version ici ;
  2. vous dézippez le fichier archive ;
  3. dans Netbeans, vous désinstallez les plugins JavaFX (menu Tools/Plugins, onglet « Installed ») ;
  4. vous ré-installez la nouvelle version que vous venez d’unzipper : menu Tools/Plugins, onglet « Downloaded », cliquez sur le bouton « Add plugins ».

Poster un commentaire

Vous devriez utiliser le HTML:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>